頭と尻尾はくれてやる!

パソコンおやじのiPhoneアプリ・サイト作成・運営日記


TensorFlowを1.2へアップデート

ずっと1.0のまま使ってたんだけど、ここいらで1.2へアップデートすることに。

Installing TensorFlow on Mac OS X  |  TensorFlow
↑本家を参考に。1.0へのアップデートと同じく Installing with native pip でやってみた。

まずはpipのバージョン確認。ターミナルから
pip3 -V とした結果、
pip 9.0.1 from /Users/yamaguchitatsuya/.pyenv/versions/anaconda3-4.1.1/lib/python3.5/site-packages (python 3.5)
で8.1以上なのでOK。

次に
pip3 install tensorflow
でインストールするも、
Requirement already satisfied
とかがいっぱい出て、ダウンロードしない。

これがダメなら、、、と本家ページにあるのでその通りにやってみたのが↓これ。
sudo pip3 install --upgrade https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.2.0-py3-none-any.whl

するとダウンロード開始し、無事終了。

print(“version “+str(tf.__version__))
↑これでバージョンを確認すると1.0.0→1.2.0になった〜!
1.1で大きな変更があったとか聞いた気がするんだけど、1.0で動いてたMNISTを試しに動かしたら普通に動いた。



memo
macOS Sierra 10.12.5
Python 3.5.2 :: Anaconda 4.1.1 (x86_64)

<< ffmpegで動画のトリミング  TopPage  機械学習で人体頭部の姿勢を得る(4) >>

コメント


管理者にだけ表示を許可する
 

トラックバック

トラックバックURL
http://ringsbell.blog117.fc2.com/tb.php/1065-87e1d99f




Copyright ©頭と尻尾はくれてやる!. Powered by FC2 Blog. Template by eriraha.

FC2Ad